Neurotel Communications - Umkomaas - Fibre – Incident details

Umkomaas - Fibre

Resolved
Degraded performance
Started 28 days agoLasted about 17 hours

Affected

Fiber

Degraded performance from 5:30 PM to 10:12 AM

Updates
  • Resolved
    Resolved

    We have implemented a fix and will continue to monitor for stability.

  • Identified
    Identified

    Good Day

    Please note that we have identified an issue that is currently causing high latency and reduced download speeds across the Neurotel Network. A fix will be implemented tonight after peak hours to avoid major disruptions.

    We apologize for any inconvenience caused.

    Kind Regards

    The Neurotel Team